Python

pipの警告「WARNING: You are using pip version x.x.x, however version y.y.y is available.」を抑止する

PythonのパッケージをPyPIからインストールする際に用いるpipコマンドで、よくある警告を抑止する方法です。 例えば、現在アクティブな環境にインストールされているパッケージ一覧を表示した際にも表示されます。pip listを実行してみます。 Package Version ---------- ------- pip 19.2.3 setuptools 41.2.0 WARNING: You are using pip version 19.2.3, however version 20.1 is available. You should consider upgrading via the 'pip install --upgrade

Python:3.xコンテナでMeCab + IPADIC + NEologdをシステム辞書として使用するためのDockerfile

python - Docker Hubで公開されているコンテナイメージをベースとして、MeCab + IPADIC + NEologdを使用するためのDockerfileを公開します。NEologdは、IPAが公開する辞書であるIPADICとの併用が推奨されています。今回は、IPADIC + NEologdを、MeCabのシステム辞書として使用し

VS Codeで「Failed to connect to Jupyter notebook」「Jupyter Server: Not Started」と表示されJupyter Notebookが起動できない場合の対処法

VS CodeでPython - Visual Studio Marketplaceの拡張機能を使用すると、Pythonで記述されたプログラムのデバッグや、Jupyter Notebook環境をVS Codeで実行できて大変重宝します。たまに、このJupyter Notebookが、以下のエラーにより起動しなくなったことがあったため、そ

DjangoやFlask(Python)アプリの開発を始めるならVS Code + Dockerが最適

VS Codeのチュートリアルを試してみました。事前に、Python、Dockerの拡張機能をインストールしておく必要があります。なお、Django、Flaskに関する説明は本記事にはありません。 Python - Visual Studio Marketplace Docker - Visual Studio Marketplace 環境 試した環境は以下の通りです。 $ sw_vers ProductName: Mac OS X ProductVersion: 10.15.3 BuildVersion: 19D76 また、pythonはHomebrew

macOS CatalinaのPythonのデフォルトを3.x.xにする

macOS Catalinaに搭載されているPythonの実行環境を3.x.xへ変更する方法です。ただ、pythonコマンドで、3.x.xを実行したいだけの記事です。Pythonの開発環境についてどうこう議論する場でないことは最初に申し上げておきます。次期のmacOSでは、Python 2.x.x系は駆逐されて

データ分析(データサイエンス)に必要な環境(Jupyter Lab)を一発で整えるワンライナー

Docker使いましょう。 GitHubで公開されている、Dockerイメージのテンプレートからコンテナを起動するだけで、データ分析に大抵の場合に必要なPythonのライブラリ(例えば、Pandas、Numpy等)が一式揃った環境を用意できます。 Dockerさえインストールされていれば、プラットフォー